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LED Display Modules
Summary of Changes
This publication contains new and updated information as indicated in the following table.

About the Product
Display modules with a light-emitting diode (LED) backlight are used by the PanelView™ Plus 6 
and PanelView Plus 700 to 1500 platforms. Earlier displays have a cold-cathode fluorescent lamp 
(CCFL) backlight.

Each display module has a catalog number and a series letter. The series letter differentiates an 
LED-backlit display from a CCFL-backlit display. You can find the series letter on the back of 
the display. See the table to identify the type of display you have.

Topic Page

Added catalog numbers for 7-inch and 10-inch displays to the front cover. Front cover

Added information for 7-inch and 10-inch displays to the About the Product section. 2

IMPORTANT If you replace a 7-inch, 10-inch, 12-inch, or 15-inch CCFL display with an LED display, you must 
upgrade the terminal firmware for the device to operate correctly. 

A firmware upgrade is not required for configured terminals that include a display module and 
logic module. The upgrade is required only when ordering an LED display module to replace an 
existing CCFL display module. 

Display Size Cat. Nos. LED Series Displays CCFL Series Displays

15-inch 2711P-RDK15C, 2711P-RDT15C, 
2711P-RDB15C, 2711P-RDT15AG Series C Series B or earlier

12-inch

2711P-RDK12C, 2711P-RDK12CK, 
2711P-RDT12C, 2711P-RDT12CK, 
2711P-RDT12AG, 2711P-RDB12C, 
2711P-RDB12CK

Series D Series C or earlier

10-inch
2711P-RDT10C, 2711P-RDB10C, 
2711P-RDK10C, 2711P-RDT10CM, 
2711P-RDB10CM

Series C Series B or earlier

7-inch

2711P-RDT7C, 2711P-RDB7C, 
2711P-RDK7C, 2711P-RDT7CM, 
2711P-RDB7CM, 2711P-RDT7CK, 
2711P-RDB7CK, 2711P-RDK7CK

Series D 
Series E:
• 2711P-RDB7C
• 2711P-RDB7CM 
• 2711P-RDB7CK

Series C or earlier
Series D or earlier:
• 2711P-RDB7C
• 2711P-RDB7CM 
• 2711P-RDB7CK
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LED Display Modules
Replace the Display Module
To replace a display module, see the appropriate manual Additional Resources on page 12.
 

Upgrade the Firmware
To locate the firmware upgrade for your terminal, follow these steps.

1. Go to http://www.rockwellautomation.com/support/pcdc.page.

2. Click the Get Downloads tab. 

3. Click Find Product Downloads.

4. From the All Families pull-down menu, choose PanelView Plus 6 700 - 1500 or 
PanelView Plus 700 - 1500.

5. Click the family selection, then choose a firmware revision from the list.

The table shows the firmware revision that is required for your terminal.

6. Click Find Downloads at the bottom of the Selections tab.

7. Under Downloads, click the show downloads  icon to access the firmware.

8. Download the upgrade file (.exe) to a temporary folder on the same drive as FactoryTalk® 
View Machine Edition (ME) software.

9. Run the upgrade file (.exe) installation procedure: 
• The FUW is installed in the FactoryTalk View ME folder. 
• The firmware upgrade package (.fup) file is installed into the folder that is specified 

during the installation procedure.

You are now ready to run the FUW to upgrade the terminal firmware from a storage device or by 
using a network connection.

IMPORTANT Before mounting the LED series display module, make sure that the logic module firmware is at 
the firmware revision that is listed in the table in Upgrade the Firmware.

You must use CCFL series display module to upgrade the firmware; the display must be for 700 
to 1500 platforms.

If no other display is available, the complete terminal must be returned to your local 
Allen-Bradley distributor for exchange or repair.

For This PanelView Plus Family Choose This Firmware Revision

PanelView Plus/PanelView Plus CE 700 to 1500 5.10.11 or later

PanelView Plus 6 700 to 1500 7.00.20130619 or later
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LED Display Modules
Firmware Upgrade Wizard
The firmware upgrade Wizard (FUW) is used to upgrade the terminal firmware. Two methods 
are provided to upgrade the firmware:

• Create a firmware upgrade card with the contents of the FUP file that you can then load 
in the terminal to upgrade the firmware.

The firmware upgrade card can be a USB flash drive, CompactFlash (CF) card, or a 
Secure Digital (SD) card, catalog number 1784-SDx.

• Upgrade firmware in a terminal that is connected to a computer over a direct network 
connection. The network connection requires a computer with RSLinx® Enterprise 
software installed.

RSLinx Enterprise software is required so you can choose the terminal to upgrade.

You can run the FUW from within FactoryTalk View Studio software or from the Programs 
menu on your computer:

• In FactoryTalk View Studio software, from the Tools menu, choose firmware upgrade 
Wizard.

• Choose Start>Programs>Rockwell Software>FactoryTalk View>Tools>ME firmware 
upgrade Wizard.

Upgrade the Terminal Firmware from a Storage Device
Upgrade the firmware from a storage device is a two-step process. First, you create a firmware 
upgrade card with the required firmware files. Second, you load the card in the target terminal to 
upgrade the firmware.

The firmware upgrade card can be a USB flash drive, CF card, or an SD card.

Create a Firmware Upgrade Card
To copy firmware files to a USB flash drive, CF card, or SD card, follow these steps.

1. Insert either a USB flash drive, CF card, or an SD card into the appropriate slot on your 
computer.

2. Run the firmware upgrade Wizard:
a. In FactoryTalk View Studio software, from the Tools menu, choose firmware 

upgrade Wizard.
b. Choose Start>Programs>Rockwell Software>FactoryTalk View>Tools>ME 

firmware upgrade Wizard.

IMPORTANT Use the latest version of RSLinx Enterprise software, which is available at https://
rockwellautomation.custhelp.com/app/answers/detail/a_id/49190.
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LED Display Modules
3. Follow these steps from the initial FUW dialog box.
a. Click Create firmware upgrade card (A).
b. Choose the location of the firmware card by browsing to the root directory of the 

storage card that is loaded in your computer (for example, H:\ or B).
The firmware files are copied to this location. You can also specify a folder on the 
hard disk drive.

c. From the Existing terminal type pull-down menu, choose a version v6.00-v7.00 
PanelView Plus 6 terminal.
The example shows that the firmware upgrade is for a 700 - 1500 PanelView Plus 6 
terminal (C).

d. Click Next (D).

A

B

C

D
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LED Display Modules
4. Follow these steps from this dialog box.
a. Browse to the location of the firmware source files on your computer, where the FUP 

was installed (E).
b. From the ‘Upgrade firmware version’ pull-down menu, choose the firmware revision 

for the upgrade (F).
c. Click Next (G).

It can take several seconds for the next dialog box to appear while the FUP is being 
retrieved.

5. Follow these steps from this dialog box.
a. Choose the KEPServer drivers that you want included in the firmware (H).
b. Click Next (I).

Kepware drivers are already installed on the PanelView Plus 6 terminals.

F

E

G

I

H
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LED Display Modules
The final dialog box summarizes your choices for creating the firmware upgrade card.

6. To upgrade the firmware in the terminal, click Finish.
 

A progress bar displays as files are copied to the USB flash drive, CF card, or SD card.

7. Click OK when the firmware upgrade completes successfully.

8. Remove the USB flash drive, CF card, or SD card from your computer.

9. To use this firmware upgrade card to upgrade the terminal firmware, proceed to the next 
section.

Upgrade Terminal Firmware by Using Firmware Upgrade Card
To transfer firmware files from the USB flash drive, CF card, or SD card to the terminal, follow 
these steps. This card is the firmware upgrade card that was created in the previous section.

TIP If the firmware files were copied to the hard disk drive, copy the files to the root directory 
of the USB flash drive, CF card, or SD card.

IMPORTANT • Do not remove or accidentally disconnect the USB flash drive, CF card, or SD card while a 
firmware upgrade is in process. This action can corrupt the firmware and make the terminal 
unstable.

• Do not power off the terminal during a firmware upgrade.
• USB hubs can produce unexpected behavior and are not recommended.
Rockwell Automation Publication 2711P-IN030B-EN-P - December 2015 7
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1. Insert the USB flash drive, CF card, or SD card into the appropriate slot on your 
terminal. 

The firmware upgrade automatically starts and displays this dialog box.

2. To start the firmware upgrade, press Upgrade or [F7] on the terminal.

The terminal restarts and displays a progress bar during the upgrade. 

When the upgrade is complete, the terminal restarts and executes the new firmware.

3. Remove the USB flash drive, CF card, or SD card from the terminal.

Upgrade Terminal Firmware over the Network
You can upgrade firmware in a terminal that is connected to a computer over a direct network 
connection. The network connection requires a computer that runs the FUW and RSLinx 
Enterprise software.

RSLinx Enterprise software is required so you can choose the terminal on the network.

To copy firmware files to the terminal over a network by using RSLinx Enterprise software and 
Ethernet communication, follow these steps.

1. Run the FUW:
a. In FactoryTalk View Studio software, from the Tools menu, choose firmware 

upgrade Wizard.
b. Choose Start>Programs>Rockwell Software>FactoryTalk View>Tools>ME 

firmware upgrade Wizard.

IMPORTANT Use the latest version of RSLinx Enterprise software, which is available at https://
rockwellautomation.custhelp.com/app/answers/detail/a_id/49190.
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LED Display Modules
2. Click ‘Upgrade firmware on terminal’ (A) and click Next (B).

3. To continue, click Yes.

It is not necessary to back up files on PanelView Plus 6 terminals.

4. Click Network Connection (using RSLinx Enterprise) (C).

This selection is the only valid selection for PanelView Plus 6 terminals.

5. Click Next (D).

A

B

C

D
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6. To receive the firmware upgrade, navigate to and select the terminal.

7. With the terminal selection highlighted, click Next.

8. Follow these steps from this dialog box.
a. Browse to the location of the firmware source files on your computer, where the FUP 

was installed.
The default location is shown (E).

b. Choose the version of the upgrade firmware from the pull-down menu (F).
c. Click Next (G).

It can take a few seconds for the next dialog box to appear while the FUP is retrieved.

IMPORTANT The highlighted selection in the figure is only for illustration purposes. Your model 
can be different.

G

E

F
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LED Display Modules
9. From this dialog box, optionally choose the KEPServer drivers that you want included in 
the firmware, then click Next.

Kepware drivers are already installed on the PanelView Plus 6 terminals.

The final dialog box summarizes your choices for upgrading the terminal firmware.

10. To upgrade the firmware in the terminal, click Finish.
 

11. To continue with the upgrade, click Yes.

A progress bar displays as firmware files are copied to the terminal.

12. Click OK when the firmware upgrade is complete.

The terminal restarts and executes the new firmware.
Rockwell Automation Publication 2711P-IN030B-EN-P - December 2015 11



Additional Resources
These documents contain additional information concerning related products from Rockwell 
Automation.

You can view or download publications at http://www.rockwellautomation.com/global/
literature-library/overview.page. To order paper copies of technical documentation, contact your 
local Allen-Bradley distributor or Rockwell Automation sales representative.

Rockwell Automation Support
For technical support, visit http://www.rockwellautomation.com/support/overview.page.

Resource Description

PanelView Plus 6 HMI Terminals User Manual, publication 
2711P-UM006 

Provides information to install, configure, operate, and troubleshoot 
PanelView Plus 6 terminals.

PanelView Plus Terminals User Manual, publication 
2711P-UM001 

Provides information to install, configure, operate, and troubleshoot 
PanelView Plus terminals.

Industrial Automation Wiring and Grounding Guidelines, 
publication 1770-4.1 

Provides general guidelines for installing a Rockwell Automation 
industrial system.

Product Certifications website,
http://www.rockwellautomation.com/global/
certification/overview.page 

Provides declarations of conformity, certificates, and other 
certification details.
Allen-Bradley, FactoryTalk, PanelView, Rockwell Software, Rockwell Automation, and RSLinx are trademarks of Rockwell Automation, Inc.

Trademarks not belonging to Rockwell Automation are property of their respective companies.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçerenköy, İstanbul, Tel: +90 (216) 5698400

Rockwell Automation maintains current product environmental information on its website at
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page.

Publication 2711P-IN030B-EN-P - December 2015
Supersedes Publication 2711P-IN030A-EN-P - October 2013 Copyright © 2015 Rockwell Automation, Inc. All rights reserved. Printed in the U.S.A.
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		SG		B1 Primary, B4		D5, D6		Selection Guide Colour		5		50		Presale / External

		SG		B2		D5, D6		Selection Guide B/W		5		50		Presale / External

		SP		A1, A2, A3, A4		NA		Sales Promotion NOTE: Service profiles are to be assigned the PP pub type.		5		100		Presale / Internal

		SR		B2, B3		D5, D6		Specification Rating Sheet		5		100		Presale / External

		TD		B2 Primary B3, B4, B5		D5, D6		Technical Data		5		50		Presale / External

		TG		B2, B3		D6		Troubleshooting Guide		1		5		Post / External

		UM		B2 Primary, B4		D6		User Manual B/W		1		5		Post / External

		WD		B3		D5		Wiring Diagrams / Dwgs		1		5		Post / Internal

		WP		B3 Primary, B5		D5		White Paper		5		50		Presale / External

		** Minimum order quantities on all JIT items are based on the publication length. **

		Publication length		Minimum Order Quantity

		77 or more pages		1 (no shrink wrap required)

		33 to 76 pages		25

		3 to 32 pages		50

		1 or 2 pages		100

		Pre-sale / Marketing		All paper in this category is White Brightness, 90% or better. Opacity 90% or better

		Category		Color Options		AP, EMEA Paper Requirements		Canada, LA, US Paper Requirements

		A1		4 color		170 gsm  2pp		100# gloss cover, 100# gloss text

		A2		4 color		170 gsm  , folded, 4pp		100# gloss cover, 80# gloss text

		A3		4 color		Cover 170 gsm  with           Body 120 gsm, > 4pp		80# gloss cover, 80# gloss text

		A4		2 color		170gsm Silk – 120gsm Silk		80# gloss cover, 80# gloss text

		A5		2 color		170gsm Silk – 120gsm Silk		80# gloss cover, 80# matt sheet text

		A6		1 color		170gsm Silk – 120gsm Silk		80# gloss cover, 80# matt sheet text

		A7		4 color cover
2 color text
Selection Guide		Category being deleted		10 Point Cover C2S
50# matte sheet text

		A8		4 color cover		Category being deleted		50# matte sheet text, self cover

				2 color text

				Selection Guide

		A9		2 color		100gsm bond		50# matte sheet text, self cover

				Selection Guide

				Gray shading indicates Obsolete Print Catagories

		Post Sale / Technical Communication

		Category		Color Options		AP, EMEA Paper Requirements		Canada, LA, US Paper Requirements

		B1		4 color cover		270gsm Gloss 100gsm bond		10 Point Cover C2S

				2 color text				50# matte sheet text

		B2		1 color		160gsm Colortech & 100gsm Bond		90# Cover
50# matte sheet text

		B3		1 color		100gsm bond		50# matte sheet text, self cover

		B4		2 color		160gsm Colortech & 100gsm Bond		90# Cover
50# matte sheet text

		B5		2 color		100gsm bond		50# matte sheet text, self cover

		Catalogs

		Category		Color Options		AP, EMEA Paper Requirements		Canada, LA, US Paper Requirements

		C1		4 color cover		270gsm Gloss 90gsm silk		10 Point Cover C2S

				4 color text				45# Coated Sheet

		C2		4 color cover		270gsm Gloss 80gsm silk		10 Point Cover C2S

				2 color text				32#-33# Coated Sheet

		JIT / POD		All paper in this category is White Brightness, 82% or better.  Opacity 88% or better

		Category		Color Options		AP, EMEA Paper Requirements		Canada, LA, US Paper Requirements

		D1		4 color		170gsm white silk		80# gloss cover, coated 2 sides

		D2		4 color		120gsm white silk		80# gloss text, coated 2 sides, self cover

		D3		4 color		Cover 170gsm  with           Body 120gsm		80# gloss cover, 80# gloss text coated 2 sides

		D4		1 color		160gsm tab		90# index

		D5		1 color		80gsm bond		20# bond, self cover

		D6		1 color		Cover 160gsm tab with Body 80gsm bond		90# index, 20# bond

		D7		2 color		160gsm tab		90# index

		D8		2 color		80gsm bond		20# bond, self cover

		D9		2 color		Cover 160gsm tab with Body 80gsm bond		90# index, 20# bond

		D10		Combination: 4 color cover, with 2 color body		Cover 160gsm with           Body 80gsm		90# index, 20# bond

				Gray shading indicates Obsolete Print Catagories

		Just In Time (JIT) or Off Set (OS)?

		Use these guidelines to determine if your publication should be JIT (just in time/print on demand) or if it would be more economical to print OS (offset/on a press). OS print jobs require an RFQ (Request For Quote) in US. If your job fits into the “Either” category, an RFQ is recommended, but not required. In the US, RA Strategic Sourcing will discourage or reject RFQs for jobs that fall within the JIT category. Guidelines differ for black & white and color printing, so be sure to check the correct tables.

		Black & White Printing

		Color Printing

		Color Printing





Print Spec Sheet

		JIT Printing Specifications				RA-QR005J-EN-P  -  6/14/2013

		Printing Specification		YOUR DATA HERE		Instructions																																				NO

		(required) Publication Number:		2711P-IN030B-EN-P		Sample: 2030-SP001B-EN-P																														11” x 17”				LOOSE -Loose Leaf		YES		Pre-sale / Marketing				TOP

		Use Legacy Number:				YES or NO																														8.5” x 11”				PERFECT - Perfect Bound				A1				LEFT

		Legacy Number if applicable:				Sample Legacy Number: 0160-5.33																														8.375” x 10.875				SADDLE - Saddle Stitch				A2				RIGHT				CORNER

		Publication Title:		LED Display Modules Installation Instructions		Sample: ElectroGuard Selling Brief
80 character limit - must match DocMan Title																														8.25” x 11” (RA product profile std)				PLASTCOIL - Plastic Coil (Coil Bound)				A4				BOTTOM				SIDE

		Used in Manufacturing:		YES		YES or NO - If Yes, must have Part No. listed below																														8.25” x 10.875”				STAPLED1 -1 position				A3

		Part Number:		PN-343686		If SAP Part Number, be sure to enter PN- before the number																														7.385” x 9” (RSI Std)				STAPLED1B - bottom 1 position				A5

		(required) Category		D5		Select Print Category A,B,C or D from category list, on "Introduction_Category Types" tab																														6” x 4”				STAPLED2 - 2 positions				A6

		Paper Stock Color:				White is assumed.  For color options contact your vendor																														5.5” x 8.5” (half-size)				THERMAL - Thermal bound (Tape bound)				A7

		Ink Color:				One color assumes BLACK / 4 color assume CMYK / Indicate PMS number here																														4.75” x 7.75”				THERMALO - Thermal Bound (Tape bound - offline)				A8

		(required) Page Count of
Publication:		12		Total page count including cover. Enter PAGE count, not SHEET count																														4.75” x 7” (slightly smaller half-size)								A9

		(required) Finished Trim Size Width:		8.5” x 11”		This is sheet size, before folding																														4.25" x 5.50"								Post Sale / Technical Communication

		Fold:		Half or V or Single Fold		Review key below. Leave blank if folded for saddle stitching																														4” x 6”								B1

		Finished Fold Size:		5.5” x 8.5” (half-size)		This is size after folding is completed																														3” x 5”								B2

		Binding/Stitching:		SADDLE - Saddle Stitch		Review key below																														9” x 12” (Folder)								B3						None

		Stitching Location:				Blank, Corner or Side																														A4 (8 ¼” x 11 ¾”) (210 x 297 mm)								B4						Half or V or Single Fold

		Drill Hole (Yes/No):		NO		All drilled publications use the 5-hole standard, 5/16 inch-size hole and a minimum of ¼ inch from the inner page border.																														A5 (5.83” x 8.26”) (148 x 210 mm)								B5						C or Tri-Fold

		Number of Tabs Needed:				5 tab in stock at RR Donnelley																														36” x 24” Poster								Catalogs						DbleParll

		Number of Pages per Pad:				Average sheets of paper. 25, 50 75,100 Max																														24” x 36” Poster								C1						Sample

		Glue Location on Pad:				Glue location on pads																														18” x 24” Poster								C2						Short (must specify dimensions between folds in Comments)

		(required) Business Group:		Marketing Commercial		As entered in DocMan																																						JIT/POD						Z or Accordian Fold

		(required) Cost Center:		19134 - IA		If your Business Unit is Marketing Commercial, add the appropriate division name after 19134 using the chart on the right. 
All other Business Units: Enter only the number as in DocMan, no description. 
Example - 19021		19134 - Commerc        19134 - OEM 
19134 - Compone        19134 - Power C
19134 - Global             19134 - Process      
19134 - IA                     19134 - Service 
19134 - IMC                  19134 - Safety       
19134 - Industr             19134 - Softwar
19134 - Mkt Dig            19134 - US Marke																																				D1						Microfold or French Fold - designate no. of folds in Comments - intended for single sheet only to be put in box for manufacturing

		Comments:																																										D2						Double Gate

						Folds
Half, V, Single                 C or Tri




Dble Parll




Z or Accordian                       Microfold or French





Double Gate

 


Short Fold		Saddle-Stitch Items 
All page quantities must be divisible by 4.
Note: Stitching is implied for Saddle-Stitch -
no need to specify in Stitching Location.
80 pgs max. on 20# (text and cover)
76 pgs max. on 20# (text) and 24# (cover)
72 pgs max. on 24# (text and cover)

Perfect Bound Items
940 pgs max. w/cover (90# index unless indicated otherwise)
70 pgs. min. for spine without words
200 pgs min. for spine with words 

Plastcoil Bound Items
530 pgs max. of 20# (if adding cover deduct equivalent number of pages to equal cover thickness) (90# index unless indicated otherwise)

Tape Bound Items
250 pgs max. on 20# no cover
240 pgs max. w/cover (90# index unless indicated otherwise)																																				D3

																																												D4

																																												D5

																																												D6

																																												D7

																																												D8

																																												D9
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